PHP is among the most widely used server-side programming languages. It’s very popular because it’s free software, which can be used to build interactive sites like social networking websites, web stores or e-teaching websites instead of static HTML-based websites. A PHP module must be activated on the server where a PHP-powered site is hosted so that its PHP code can be ‘decoded’. Since there aren’t any license charges for this type of module and the language itself provides infinite possibilities for the web apps that you develop, there are hundreds of millions of PHP-driven websites. Plus, there are a lot of open-source PHP-based scripts, which you can use for your websites without needing to possess any coding abilities. As there’re several versions of PHP, you ought to verify that the very same version that you used while building your website is activated on the web server as well.

PHP 4 and PHP 5 Support in Web Hosting

With our web hosting, you will be able to pick the PHP version that will be active for your shared hosting account, since different versions are available on our servers. With just one mouse click, you’ll be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and every time a new version is introduced in the future, we will add it to the Hepsia hosting Control Panel without removing the earlier ones. Thus, you will be able to host all the sites that you’ve built through the years. Unlike a lot of other web hosts, we won’t compel you to update such websites, because a script may be out of date, but this doesn’t necessarily mean that it is insecure since you may have performed modifications to its source code to prevent safety loopholes. For the sake of your convenience, you will even be able to specify a different PHP version for each site hosted in your web hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Our semi-dedicated servers support multiple PHP versions, which goes to say that you’ll be able to run all the web-based applications that you have built over the years. The Hepsia hosting Control Panel, which comes bundled with every account, will allow you to activate the required version with one single click. You can choose between PHP 5.5, 5.4, 5.3, 5.2 and 4. In case you would like to host multiple sites in the exact same account and they have different requirements as to the web hosting environment, you will be able to specify a different version for each of them no matter which version is selected for the account as a whole. That’s possible owing to our in-house created cloud platform, which allows us to run several PHP versions at once. In comparison, most web hosting providers typically support one, in rare cases – two versions.